Install libruby18_1 on Solaris 10 and 11:

pkgadd -d http://get.opencsw.org/now
/opt/csw/bin/pkgutil -U
/opt/csw/bin/pkgutil -y -i libruby18_1 
/usr/sbin/pkgchk -L CSWlibruby18-1 # list files

See also: Getting started with OpenCSW

Package details

Catalognamelibruby18_1
SVR4 package nameCSWlibruby18-1
DescriptionThe libruby.so.1* files (Ruby 1.8)
Version1.8.7p357,REV=2016.03.03
Source URL ftp://ftp.ruby-lang.org/pub/ruby/
Package Sources csw/mgar/pkg/ruby18/trunk/Makefile (SourceForge, OpenGrok)
QA pageGo to libruby18_1 QA page
Last Uploaded ByJan Holzhueter
Contact maintainer
Bugtracker View bugs about libruby18_1
View files in package

Dependencies ( 1 )

Oracle / Sun Solaris SUNW packages not shown.

Software nameDescription
commoncommon files and dirs for CSW packages

Reverse dependencies ( 9 )

Reverse dependencies are Solaris packages that depends on libruby18_1.

Software nameDescription
graphvizrubyGraphviz language binding for ruby
rb18_geos3_3_3Geometry Engine, Open Source, ruby 1.8 bindings
rb18_json_1_5_3JSON Implementation for Ruby
rb18_libxml_1_1_4Ruby libxml bindings
rb18_mysql_2_8_1This is the MySQL API module for Ruby
rb_rrdtoolRuby binding for RRD access (part of RRDtool)
ruby18An object-oriented language for quick and easy programming.
ruby18_devRuby 1.8 Extension Development Files
ruby18_tkRuby 1.8 Tcl/TK Extension

Libraries dependencies ( 8 )

The following tables display the sub list of packages, from the reverse dependencies, that depends on the libs provided by libruby18_1.

DependencySoftware name
libruby18.so.1 graphvizruby
libruby18.so.1 rb_rrdtool
libruby18.so.1 rb18_geos3_3_3
libruby18.so.1 rb18_json_1_5_3
libruby18.so.1 rb18_libxml_1_1_4
libruby18.so.1 rb18_mysql_2_8_1
libruby18.so.1 ruby18
libruby18.so.1 ruby18_tk