After someone removed /etc/passwd I'm having issues with some packages not starting correctly under Solaris 10 SMF. (Hint for recovering /etc/passwd and /etc/shadow, look for opasswd and oshadow.) I can see the snmp packages are installed but when I run ‘svcs –a|grep –I snmp” nothing is there. I can find the manifest file (/var/opt/csw/svc/manifest/network/netsnmpd.xml) and if I run the start from the XML file (/var/opt/csw/svc/method/svc-netsnmpd start) snmpd runs. What am I missing? Do I have to reinstall the packages: libnetsnmp25 libnetsnmp30 libnetsnmpagent25 libnetsnmpagent30 libnetsnmpmibs25 libnetsnmpmibs30 libnetsnmptrapd25 libnetsnmptrapd30 netsnmp pm-net-snmp pm-netsnmp

asked 04 Oct '16, 15:29

essej1's gravatar image

essej1
111
accept rate: 0%


No idea what happens there, but you can re import the SMF

# svccfg import /var/opt/csw/svc/manifest/network/netsnmpd.xml
permanent link

answered 04 Oct '16, 15:39

cgrzemba's gravatar image

cgrzemba ♦♦
6091318
accept rate: 9%

Thanks. That did the trick.

permanent link

answered 04 Oct '16, 16:00

essej1's gravatar image

essej1
111
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×4

question asked: 04 Oct '16, 15:29

question was seen: 83 times

last updated: 04 Oct '16, 16:00

powered by OSQA